HDU 1198 Farm Irrigation(DFS)


Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9661    Accepted Submission(s): 4225


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
  
  
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 

Sample Output
  
  
2 3
 

Author
ZHENG, Lu
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1272  1811  1829  1558  1325 
 

Statistic |  Submit |  Discuss |  Note

先把已知条件变成图再进行DFS

如A变成         E变成         I变成                       

101                 101            111                           

001                 101            000                           

111                 101            101                     

即0为通路,1为不通路。油田  变形                    

变图的过程一言难尽。。。每3*3部分四个角都为1,然后再设5个位置的0/1

边界都要*3


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
char map[200][200];
int nn,mm;
int dir[4][2]={1,0,-1,0,0,-1,0,1};
void find(char a,int b,int c){
	int i,j;
	map[b][c]='1';map[b+2][c]='1';map[b][c+2]='1';map[b+2][c+2]='1';
	switch(a){
		case 'A':map[b][c+1]='0';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='1';map[b+2][c+1]='1';break;
		case 'B':map[b][c+1]='0';map[b+1][c]='1';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='1';break;
		case 'C':map[b][c+1]='1';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='1';map[b+2][c+1]='0';break;
		case 'D':map[b][c+1]='1';map[b+1][c]='1';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='0';break;
		case 'E':map[b][c+1]='0';map[b+1][c]='1';map[b+1][c+1]='0';map[b+1][c+2]='1';map[b+2][c+1]='0';break;
		case 'F':map[b][c+1]='1';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='1';break;
		case 'G':map[b][c+1]='0';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='1';break;
		case 'H':map[b][c+1]='0';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='1';map[b+2][c+1]='0';break;
		case 'I':map[b][c+1]='1';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='0';break;
		case 'J':map[b][c+1]='0';map[b+1][c]='1';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='0';break;
		case 'K':map[b][c+1]='0';map[b+1][c]='0';map[b+1][c+1]='0';map[b+1][c+2]='0';map[b+2][c+1]='0';break;
	}
}
void dfs(int a,int b){
	int aa,bb,i;
	for(i=0;i<4;i++){
		aa=a+dir[i][0];
		bb=b+dir[i][1];
		if(aa>=0&&aa<nn&&bb>=0&&bb<mm&&map[aa][bb]=='0'){
			map[aa][bb]='1';
			dfs(aa,bb);
		}
	}
}
int main(){
	int i,j,n,m,ii,jj,sum;
	char ch;
	while(scanf("%d%d",&n,&m)&&n!=-1&&m!=-1){
		memset(map,0,sizeof(map));
		getchar();
		ii=0;
		for(i=0;i<n;i++){
			jj=0;
			for(j=0;j<m;j++){
				scanf("%c",&ch);
				find(ch,ii,jj);
				jj=jj+3; 
			}
			ii=ii+3;
			getchar();
		}
		nn=n*3; mm=m*3;
		/*
		printf("可以输出这个矩阵观察一下");
		for(i=0;i<nn;i++){
			for(j=0;j<mm;j++){
				printf("%c",map[i][j]);
			}
			printf("\n");
		}  printf("********\n"); 
		*/
		sum=0;
		for(i=0;i<nn;i++){
			for(j=0;j<mm;j++){
				if(map[i][j]=='0'){
					map[i][j]=='1';
					dfs(i,j);
					sum++;
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值