HDU 1198 Farm Irrigation ( dfs )

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10978    Accepted Submission(s): 4809


Problem Description
Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1


Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

ADC
FJK
IHE

then the water pipes are distributed like 


Figure 2


Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.
 

Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 

Output
For each test case, output in one line the least number of wellsprings needed.
 

Sample Input
 
 
2 2
DK
HF
3 3
ADC
FJK
IHE
-1 -1
 

Sample Output
 
 
2
3
这个题想到构图,但没想到上下左右每个方向只用1或0表示,想的是用类似(1,0)这样表示一个,但是那样太麻烦,分情况太多,看了别人的构图,很简单。自己想不起来。。。。
#include<stdio.h>
#include<string.h>
using namespace std;
int f[4][2]={-1,0,1,0,0,-1,0,1};//上下左右 
int map[11][4]={//地图的分布,上下左右,1代表通,0代表不通 
{1,0,1,0},{1,0,0,1},
{0,1,1,0},{0,1,0,1},
{1,1,0,0},{0,0,1,1},
{1,0,1,1},{1,1,1,0},
{0,1,1,1},{1,1,0,1},{1,1,1,1}
};
int m,n;
char mat[55][55]; 
int vis[55][55]; 
void dfs(int x,int y)
{
	vis[x][y]=1;//走过的为1 
	for(int i=0;i<4;i++)
	{
		int xx=x+f[i][0];
		int yy=y+f[i][1];
		int j;
		if(i==0||i==1)
		{
			j=(i+1)%2;
		}
		else if(i==2)
		{
			j=3;
		}
		else j=2;
		if(!vis[xx][yy]&&xx<n&&xx>=0&&yy<m&&yy>=0&&map[mat[x][y]-'A'][i]==1&&map[mat[xx][yy]-'A'][j]==1)
		{//后两个是方向的变换,map[mat[x][y]-'A'][i]==1代表当前方向通的,map[mat[xx][yy]-'A'][j]==1代表走的下个格子是有路的
			//举个栗子,当前向下走,当前格子向下要通之外,还要下一个格子向上来有路 
			dfs(xx,yy);
		}
	}
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&(n!=-1&&m!=-1))
	{
		getchar();
		int sum=0;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++)
			scanf("%s",mat[i]);
		for(int i=0;i<n;i++)
			for(int j=0;j<m;j++)
			{
				if(!vis[i][j])//判断多少个连通分量 
				{
					sum++; 
					dfs(i,j);
				}
			}
		printf("%d\n",sum);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值