数据结构实验之二叉树的建立与遍历

题目描述
       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。


输入
 输入一个长度小于50个字符的字符串。
输出
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
示例输入
abc,,de,g,,f,,,
示例输出
cbegdfa
cgefdba
3

5


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *l,*r;
};
int count=0;
struct node *root;
struct node *creat(struct node *root)
{
    char t;
    scanf("%c",&t);
    if(t==',')
        root=NULL;
    else
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->data=t;
        root->l=creat(root->l);
        root->r=creat(root->r);
    }
    return root;
}
void zhongxu(struct node *root)
{
    if(root)
    {
        zhongxu(root->l);
        printf("%c",root->data);
        zhongxu(root->r);
    }
}
void houxu(struct node *root)
{
    if(root)
    {
        houxu(root->l);
        houxu(root->r);
        printf("%c",root->data);
    }
}
int jiedian(struct node *root)
{
    if(root)
    {
        if((root->l==NULL)&&(root->r==NULL))
            count++;
            jiedian(root->l);
            jiedian(root->r);
    }
    return 0;
}
int deep(struct node *root)
{
    int ll,rr;
    if(root==NULL)
        return 0;
    ll=deep(root->l);
    rr=deep(root->r);
    return ll>rr?ll+1:rr+1;
}
int main()
{
    root=creat(root);
    zhongxu(root);
    printf("\n");
    houxu(root);
    printf("\n");
    jiedian(root);
    printf("%d\n",count);
    printf("%d\n",deep(root));
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值