求二叉树的先序遍历

题目描述
 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
输入
 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 
输出
 输出二叉树的先序遍历序列
示例输入
2
dbgeafc

dgebfca

lnixu

linux


示例输出
abdegcf

xnliu


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    char data;
    struct node *l,*r;
};
struct node *creat(int len ,char *s1,char *s2)
{
    struct node *root;
    int i;
    root=(struct node *)malloc(sizeof(struct node));
    if(len==0)
    return NULL;
    root->data=s2[len-1];  //后序中最后一个是结点
    for(i=0;i!=len;i++)//在中序中找结点
    {
        if(s1[i]==s2[len-1])
        break;
    }
    printf("%c",root->data);
    root->l=creat(i,s1,s2);
    root->r=creat(len-i-1,s1+i+1,s2+i);
    return root;
};
int main()
{
    int t,len;
    char s1[100],s2[100],n;
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s %s",s1,s2);
        len=strlen(s1);
        root=creat(len,s1,s2);
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值