数据结构实验之链表五:单链表的拆分

数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;
第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001

示例输出

4 6
22 8 44 6 
1 3 15 999 9 1001

提示

不得使用数组!


#include<iostream>
#include<string>
#include<cstdlib>
using namespace std;
struct node
{
    int data;
    struct node *next;
};
struct node *head,*tail,*head2,*tail2,*p,*q;

int main()
{
    int n,x,y;
    x=0;y=0;
    
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    
    cin>>n;
    for(int i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        cin>>p->data;
        p->next=NULL;
        
        tail->next=p;
        tail=p;
    }
    
    head2=(struct node *)malloc(sizeof(struct node));
    head2->next=NULL;
    tail2=head2;
    p=head->next;
    q=p->next;
    head->next=NULL;
    tail=head;
    while(p)
    {
        if(p->data%2==0)
        {
            p->next=NULL;
            tail->next=p;
            tail=p;
            x++;
        }
        else
        {
            p->next=NULL;
            tail2->next=p;
            tail2=p;
            y++;
        }
        p=q;
        if(q)q=q->next;
    }
    cout<<x<<" "<<y<<endl;
    p=head->next;
    while(p->next)
    {
        cout<<p->data<<" ";
        p=p->next;
    }
    cout<<p->data<<endl;
    q=head2->next;
    while(q->next)
    {
        cout<<q->data<<" ";
        q=q->next;
    }
    cout<<q->data<<endl;
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值