进制转换 sicily1240


1240. Faulty Odometer

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440

本题可以看成是十进制转换成九进制

且要把大于4的数减1,一开始以为又要用高精度 结果用long就行了  不用那么麻烦。


// Problem#: 1240
// Submission#: 2481338
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
using namespace std;

int main() {
    while(true) {
        string a;
        cin >> a;
        if(a=="0")
            break;
        int num[10];
        int alen = a.length();
        for(int i = 0;i < alen;i ++) {
            num[i] = a[alen - 1 - i] - '0';
        }
        
        for(int i = 0; i < alen;i ++) {
            if(num[i] > 4) {
                num[i]--;
            }
        }
        long result = 0;
        long pow = 1;
        for(int i = 0;i < alen;i ++) {
            result += num[i] * pow;
            pow *= 9;
        }
        cout << a << ": "<< result <<endl;
    }
    return 0;
}                                 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值