题目描述
已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。
输入
输出
示例输入
2 abd,,eg,,,cf,,, xnl,,i,,u,,
示例输出
abcdefgxnuli
#include <iostream>
#include <cstdio>
#include <queue>
#include <bits/stdc++.h>
#include <cstdlib>
using namespace std;
struct node
{
char data;
struct node*l,*r;
};
int i;
char s[60];
struct node*creat(struct node*t)
{
if(s[i]==',')
{
t=NULL;
i++;
}
else
{
t=(struct node*)malloc(sizeof(struct node));
t->data=s[i];
i++;
t->l=creat(t->l);
t->r=creat(t->r);
}
return t;
}
void cengxu(struct node*t)
{ queue<struct node*>q;
if(t)
{
q.push(t);
printf("%c",t->data);
}
while(!q.empty())
{
t=q.front();
q.pop();//进一个元素出一个元素此时空
if(t->l)
{
printf("%c",t->l->data);
q.push(t->l);
}
if(t->r)
{
printf("%c",t->r->data);
q.push(t->r);
}
}
}
int main()
{
int n;
struct node*t;
scanf("%d",&n);
while(n--)
{
i=0;
scanf("%s",s);
t=creat(t);
cengxu(t);
printf("\n");
}
return 0;
}