数据结构实验之二叉树五:层序遍历(数组模拟队列)

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
  输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是 一个长度小于50个字符的字符串。
Output
  输出二叉树的层次遍历序列。
Example Input
2
abd,,eg,,,cf,,,
xnl,,i,,u,,
Example Output
abcdefg
xnuli
Hint
 
Author
#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
struct node
{
   char data;
   struct node*l,*r;
};
int i;
struct node*creat(struct node*t,char s[])
{
    if(s[i]==',')
    {
       t=NULL;
       i++;
    }
    else
    {
       t=(struct node*)malloc(sizeof(struct node));
       t->data=s[i];
       i++;
       t->l=creat(t->l,s);
       t->r=creat(t->r,s);
    }
    return t;

}
struct node* a[60];
void cengxu(struct node*t)
{
    int f=0,r=0;
    if(t)
    {
       a[r++]=t;
       printf("%c",t->data);
    }
    while(f!=r)
    {
       struct node*c=a[f++];
       if(c->l)
       {
          printf("%c",c->l->data);
          a[r++]=c->l;
       }
       if(c->r)
       {
          printf("%c",c->r->data);
          a[r++]=c->r;
       }
    }
}
int main()
{
    char s[60];
    struct node*t;
    int T;
    cin>>T;
    while(T--)
    {  i=0;
       scanf("%s",s);
       t=creat(t,s);
       cengxu(t);
       printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值