Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
#include <iostream>

using namespace std;
bool mp[10][10];
char s[10][10];
int flag=0,step;
int judge()
{  int i,j;
   for(i=0;i<4;i++)
   {
       for(j=0;j<4;j++)
       {
           if(mp[0][0]!=mp[i][j])
             return 0;
       }
   }
   return 1;
}
void turn(int i,int j)
{
    mp[i][j]=!mp[i][j];
    if(i>=1)
    mp[i-1][j]=!mp[i-1][j];
    if(i<3)
        mp[i+1][j]=!mp[i+1][j];
    if(j>=1)
        mp[i][j-1]=!mp[i][j-1];
    if(j<3)
        mp[i][j+1]=!mp[i][j+1];
}
int dfs(int i,int j,int dp)
{
   if(dp==step)//移动到规定步数进入函数判定是否全黑或白
   {
      flag=judge();
   }
   if(flag==1||i==4)//i==4棋盘全部走完
    return 0;
   turn(i,j);//变动棋子
   if(j<3)
    dfs(i,j+1,dp+1);
   else dfs(i+1,0,dp+1);//下一行
   turn(i,j);//移动后返回函数时变回棋子,如果flag=1无影响,flag!=1该棋子不可下变回重新找下一步
   if(j<3)
    dfs(i,j+1,dp);
   else dfs(i+1,0,dp);
   return 0;
}
int main()
{
    int i,j;
    for(i=0;i<4;i++)
    {
        for(j=0;j<4;j++)
        {
            cin>>s[i][j];
            if(s[i][j]=='w')
                mp[i][j]=0;
            else mp[i][j]=1;
        }
    }
    for(step=0;step<=16;step++)//最多移动全盘
    {
        dfs(0,0,0);
        if(flag)
            break;
    }
    if(flag)
        cout<<step<<endl;
    else cout<<"Impossible"<<endl;

    return 0;
}
<span><span>题目大意:</span>有一个4*4的方格,每个方格中放一粒棋子,这个棋子一面是白色,一面是黑色。游戏规则为每次任选16颗中的一颗,把选中的这颗以及它四周的棋子一并反过来,当所有的棋子都是同一个颜色朝上时,游戏就完成了。现在给定一个初始状态,要求输出能够完成游戏所需翻转的最小次数,如果初始状态已经达到要求输出0。如果不可能完成游戏,输出Impossible。</span> 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值