Eqs(暴力哈希)

Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 15997 Accepted: 7846

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

求五元三次方程解的个数

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
short hs[25000001];
int main()
{
    int a1,a2,a3,a4,a5,sum,ans=0;
    memset(hs,0,sizeof(hs));
    scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5);
    for(int i=-50;i<=50;i++)
       {
          if(i==0)
          continue;
          for(int j=-50;j<=50;j++)
          {
              if(j==0)
              continue;
              sum=-1*(a1*i*i*i+a2*j*j*j);
              if(sum<0)
              sum+=25000000;
              hs[sum]++;
          }
       }
       for(int i=-50;i<=50;i++)
           {  if(i==0)
              continue;
              for(int j=-50;j<=50;j++)
              {    if(j==0)
                     continue;
                  for(int k=-50;k<=50;k++)
                  {
                      if(k==0)
                      continue;
                      sum=a3*i*i*i+a4*j*j*j+a5*k*k*k;
                      if(sum<0)
                      sum+=25000000;
                      ans+=hs[sum];

                  }
              }
           }
           printf("%d\n",ans);
    return 0;
}


先将方程变化成-(a1*x1^3+a2*x2^3) = a3*x3^3+a4*x4^3+a5*x5^3,如此一来缩短了时间复杂度,否则直接五个嵌套for循环必然会超时的

其次,我们把sum作为下标,那么hash数组的上界就取决于a1 a2 x1 x2的组合,四个量的极端值均为50

因此上界为 50*50^3+50*50^3=12500000,由于sum也可能为负数,因此我们对hash[]的上界进行扩展,扩展到25000000,当sum<0时,我们令sum+=25000000存储到hash[],负数就改为正数表示了

由于数组很大,必须使用全局定义

同时由于数组很大,用int定义必然会MLE,因此要用char或者short定义数组,推荐short


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值