cigarettes

cigarettes

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 2
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
#include<stdio.h>
int sum;
int mod;

int main()
{
	void change(int unfinish,int finish);
	int times;
	int n;

	scanf("%d",&times);

	while(times--)
	{
		scanf("%d%d",&n,&mod);
		sum=0;
		change(n,0);
		printf("%d\n",sum);
	}
	return  0;
}

void change(int unfinish,int finish)
{
	int a;
	int b;
	
	if((unfinish+finish)/mod==0)	{ sum=sum+unfinish; return;}
	sum=sum+unfinish;
	
	a=(unfinish+finish)/mod;
	b=(unfinish+finish)%mod;

	change(a,b);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值