HDU ACM 1060 Leftmost Digit [数学题]

原题描述

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4

Sample Output

2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

解题思路

转一个Discuss里面的解析。
Posted by 2015gdutZhuhui at 2015-11-03 00:31:10 on Problem 1060

需要用到科学记数法和对数运算的知识。
我们把num*num的值记作:num*num=a*10^n,其中1< a <10;
那么,通过两边取对数的方法得到log10(num*num)=log10(a)+n,这时0 < log10(a) < 1;
令x=n+log10(a),得到log10(a)=x-n;所以a=10^(x-n);
n为整数部分,log10(a)为小数部分,由x=n+log10(a),可知(int)x=n;
最终a=10^(x-n)=10^(x-(int)x)!

参考代码

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        while (t--)
        {
            unsigned int n;
            scanf("%d", &n);
            double x = n * log10(n*1.0);
            x -= (__int64)x;
            int a = pow(10.0, x);
            printf("%d\n", a);
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值