Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
using namespace std;
int k[200010],a[200010];
queue<int>q;
void bfs(int x,int y)
{
    long long int t,t1,t2,t3;
    q.push(x);
    a[x]=1;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        t1=2*t;t2=t+1;t3=t-1;
        if(t1==y||t2==y||t3==y)
        {
            k[y]=k[t]+1;
            break;
        }
        if(t1<=200000&&a[t1]==0)
        {
            q.push(t1);
            a[t1]=1;
            k[t1]=k[t]+1;
        }
        if(t2<=200000&&a[t2]==0)
        {
            q.push(t2);
            a[t2]=1;
            k[t2]=k[t]+1;
        }
        if(t3>=0&&a[t3]==0)
        {
            q.push(t3);
            a[t3]=1;
            k[t3]=k[t]+1;
        }
    }
}
int main()
{
    long long int m,n;
    while(scanf("%lld%lld",&m,&n)!=EOF)
    {
        memset(k,0,sizeof(k));
        memset(a,0,sizeof(a));
        while(!q.empty())
            q.pop();
        if(m>=n)
            printf("%lld\n",m-n);
        else
        {
            bfs(m,n);
            printf("%d\n",k[n]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值