最大子矩阵和(To the max) 杭电1081

To the Max

Description

 

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

Input

 

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

 

Output

 

Output the sum of the maximal sub-rectangle.

 

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4  1
-1 8  0 -2

Sample Output

15

题意:

给 N*N 的矩阵,找出某一个子矩阵,将其所有元素相加求和,求最大的和

即找一个最大的子矩阵和

例如:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

思路:

二维的直接求解太麻烦,我们转化成一维来求解

子矩阵也可以看成是原矩阵的某几行和某几列的和

上述例子可以看成是 第2行到第四行每一列相加求和,然后转化成一维的求一个最大字段和

比如:将第2行到第4行每一列相加求和得到: 4 11 -10 1

对这个一维数组求一个最大字段和结果是 15

因此:

我们可以遍历行与行的组合,对每一列求和,然后求最大字段和

行与行的组合关系有:1  1-2  1-3  1-4

                                     2  2-3  2-4  

                                     3  3-4

                                     4

因此遍历这几种关系队列求和即可

解决方法:

① 用三维数组sum[i][j][k]  分别代表 从第 i 行到第 j 行的第 k 列的和

② 对①中求得的结果进行最大字段和,我用的是动归

CODE: 

#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#define memset(a,n) memset(a,n,sizeof(a))
const int MAXX = 110;
using namespace std;
int sum[MAXX][MAXX][MAXX];
int dp[MAXX];
int n;
int maxSum(int r,int c)
{
    int maxx = 0;
    for(int i=0; i<n; i++){
        if(i == 0)
            dp[i] = sum[r][c][i];
        else {
            dp[i] = max(sum[r][c][i],dp[i-1]+sum[r][c][i]);
        }
        if(dp[i] > maxx)
            maxx = dp[i];
    }
    return maxx;
}
int main()
{
    int maxx,maxx1,maxx2;
    int a[MAXX][MAXX];
    memset(a,0);
    memset(sum,0);
    cin >> n;
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            cin >> a[i][j];
    maxx = -1;
    for(int i=0; i<n; i++){
        for(int k=0; k<n; k++)
            sum[i][i][k] = a[i][k];
        maxx1 = maxSum(i,i); // 对第 i 行进行最大字段和
        for(int j=i+1; j<n; j++){
            for(int k=0; k<n; k++){
                sum[i][j][k] = sum[i][j-1][k] + a[j][k];
            }
            maxx2 = maxSum(i,j); // 对从第i行到第j行求的和进行最大字段和
            maxx = max(max(maxx1,maxx2),maxx);
        }
    }
    cout << maxx << endl;
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值