POJ 2503 Babelfish(hash + map)

Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41466 Accepted: 17610

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog   ogday
cat   atcay
pig   igpay
froot   ootfray
loops   oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

解析:从后边单词中查找前边单词
应用到两个知识点
1、sscanf(a"%s %s",&b,&c)是将a分为b和c两部分,以空格为分界线;
2、STL—map容量,map<类型1, 类型2 >mapname;可以表式所有的mapname[类型1]=类型2;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;

int main()
{
  map<string, string>word;
  char a[50],L[20],S[20],M[20];
  int i;
  while(gets(a)&&a[0]!='\0')
    {
      sscanf(a,"%s%s",&S,&L);
      word[L]=S;
    }
  while(cin>>M)
    {
      if(word.find(M)!=word.end())
        {
          cout<<word[M]<<endl;
        }
      else
        {
          cout<<"eh"<<endl;
        }
    }
  return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值