POJ 3041Asteroids(二分图)

Language:

Asteroids

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21046 Accepted: 11430

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.


OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Sourc

题意:在n*n的矩阵里,有k个点,消除一个点,可以消除这一点所在的行和列中的所有点,最少消除几个点可以把所有点消除。

题解:最小点覆盖问题,用到二分图的最大匹配,把每个点的横纵坐标看作链接第x边和第y边的连线。


#include <iostream>
#include <string.h>
using namespace std;

int Map[505][505]; //记录连接x和y的边,如果i和j之间有边则为1,否则为0  
int div[505];//记录i中节点是否使用 0表示没有访问过,1为访问过  
int match[505]; //记录当前与y节点相连的x的节点  
int n;
int Dfs(int k)
{
    int i;
    for(i = 1; i <= n; i++)
    {
        if(div[i] == 0 && Map[k][i] == 1)
        {
            div[i] = 1;
            if(match[i] == -1 || Dfs(match[i]))
            {
                match[i] = k;
                return 1;//说明找到了需要的连线,并且不影响之前的连线
            }
        }
    }
    return 0;//1、不存在和k相连的边。2、对之前的连线产生了影响
}

int main()
{
    int i, m, x, y, s;
    while(cin>>n>>m)
    {
        memset(Map, 0, sizeof(Map));
        memset(match, -1, sizeof(match));
        for(i = 0; i < m; i ++)
        {
            cin>>x>>y;
            Map[x][y] = 1;
        }
        s = 0;
        for(i = 1; i <= n; i++)
        {
            memset(div, 0, sizeof(div));//  清零,保证每次正常查找
            if(Dfs(i))
                s++;
        }
        cout<<s<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值