Surprising Strings
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7000 | Accepted: 4531 |
Description
The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string isD-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.
Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)
Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue ofScientific American.
Input
The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.
Output
For each string of letters, output whether or not it is surprising using the exact output format shown below.
Sample Input
ZGBG X EE AAB AABA AABB BCBABCC *
Sample Output
ZGBG is surprising. X is surprising. EE is surprising. AAB is surprising. AABA is surprising. AABB is NOT surprising. BCBABCC is NOT surprising.
Source
题意:什么是惊奇的串,拿ZGBG来说吧,成对连续的字符ZG和BG,然后相隔的字符ZB和GG,再之后是相隔两个的对ZG,这五个都不一样就是惊奇的。AABB来说,存在的字符对是AA, BB, AB, AB, AB,有重复的就不是惊奇的。
题解:简单的哈希,但map更加的简单。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <map>
using namespace std;
int main()
{
int i, j, n;
char str[80];
while(~scanf("%s", str) && strcmp(str, "*") != 0)
{
n = strlen(str);
int flag = 0;
for(i = 0; i < n ; i++)
{
map<string, int> ma;
char a[2];
for(j = 0; j < n - i; j++)
{
a[0] = str[j];
a[1] = str[j+i+1];
if(ma[a] == 1)
{
flag = 1;
break;
}
ma[a] = 1;
}
}
if(flag == 0)
printf("%s is surprising.\n", str);
else
printf("%s is NOT surprising.\n", str);
}
return 0;
}