Find them, Catch them
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 43751 | Accepted: 13478 |
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1 5 5 A 1 2 D 1 2 A 1 2 D 2 4 A 1 4
Sample Output
Not sure yet. In different gangs. In the same gang.
Source
题意:有两个帮派。。。
给出n,m分别表示有n个罪犯和m个关系,
接下来m行,每行三个东西,如果是D,u和v就不是同一帮派,如果是A就询问u和v是否是同帮派。
题解:种类并查集。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <queue>
using namespace std;
int pr[100100], rank[100100];//分别表示父节点(用于判断是否出现过)、与父节点的关系(就俩种0-1)。
int find(int x)
{
if(x==pr[x])
return x;
int y = pr[x];
pr[x] = find(pr[x]);
rank[x] = (rank[x] + rank[y])%2;
return pr[x];
}
void judge(int x, int y)
{
int xroot = find(x);
int yroot = find(y);
pr[xroot] = yroot;//统一父节点
rank[xroot] = (rank[x] + rank[y] + 1)%2;//与父节点的关系标记不同
}
int main()
{
int T, i, n, m, j, u, v;
char str[2];
scanf("%d\n", &T);
int h = 0;
while(T--)
{
scanf("%d %d", &n, &m);
for(i = 1; i <= n; i++ )
{
rank[i] = 0;
pr[i] = i;
}
for(i = 0; i < m; i++)
{
scanf("%s", str);
scanf("%d %d", &u, &v);
if(str[0] == 'D')
{
judge(u, v);
}
else if(str[0] == 'A')
{
int xroot = find(u);
int yroot = find(v);
if(xroot != yroot)
{
printf("Not sure yet.\n");
continue;
}
else
{
if(rank[u] != rank[v])
printf("In different gangs.\n");
else
printf("In the same gang.\n");
}
}
}
}
return 0;
}