HDU Coins(dp)

Coins

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13459    Accepted Submission(s): 5383

 

 

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

 

 

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

 

 

Output

For each test case output the answer on a single line.

 

 

Sample Input

 

3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0

 

 

Sample Output

 

8 4

 


Source
题意:n是有几种金币,m是总的价格,a数组是金币的价值,c数组是对应金币的数量,求解这些金币可以组成的小于m的价值。

题解:

对于每个硬币而言:
1、ai*ci>=m,就是完全背包。
2、ai*ci<m,就是多重背包,处理方法就是二进制转换为0-1背包来处理。

 

#include <stdio.h>
#include <iostream>
#include <string.h>

using namespace std;
const int inf = -0X3f3f3f3f;

int a[100100], c[100100];
int dp[100100];
int m;

void slove(int p, int w)//p价值,w数量
{
    int i, j;
    if(w*p >= m)
    {
        for(int j = p; j <= m; j++)
        {
            dp[j] = max(dp[j], dp[j-p] + p);
        }
    }
    else
    {
        int k = 1;
        while(k <= w)
        {
            for(i = m; i >= k*p; i--)
            {
                dp[i] = max(dp[i], dp[i-k*p]+k*p);
            }   
            w -= k;
            k*=2;
        }
        for(i = m; i >= w*p; i--)
        {
            dp[i] = max(dp[i], dp[i-w*p]+w*p);
        }
    }
}

int main()
{
    int n, i, j;
    while(~scanf("%d%d", &n, &m)&&(n||m))
    {
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &c[i]);
        }
        memset(dp, inf, sizeof(dp));
        dp[0] = 0;
        for(i = 1; i <= n; i++)
        {
            slove(a[i], c[i]);
        }
        int sum = 0;
        for(i = 1; i <= m; i++)
        {
            if(dp[i]>0)
                sum++;
        }
        printf("%d\n", sum);
    }
}




 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值