HDU-2844 Coins(完全背包)

Coins

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 11 Accepted Submission(s) : 6
Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3…An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn’t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3…An and C1,C2,C3…Cn corresponding to the number of Tony’s coins of value A1,A2,A3…An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3…An,C1,C2,C3…Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4

完全背包+二进制优化。 很模板的一道题
唯一不同的是 初始化部分 这道题是初始化为负无穷。
code:

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int dp[120005];
int n ,m;
void ZeroPack(int weight)
{
    for(int i=m;i>=weight;i--)
       if(dp[i-weight]+weight>dp[i])
            dp[i]=dp[i-weight]+weight;
}
void CompletePack(int weight)
{
    for(int i=weight;i<=m;i++)
        if(dp[i-weight]+weight>dp[i])
            dp[i]=dp[i-weight]+weight;
}
void MulPack(int weight, int n)
{
    if(weight*n>=m)
    {
        CompletePack(weight);
        return;
    }
    else
    {
        int k=1;
        while(k<=n)
        {
            ZeroPack(k*weight);
            n=n-k;
            k=k*2;
        }
        ZeroPack(weight*n);
//    for (int i=1; i<=n; i++)
//    {
//        ZeroPack(weight);
//    }
    }

}
int main()
{
    int value[1003], num[1003];
    while(~scanf("%d%d",&n,&m),m+n!=0)
    {
        for (int i=0; i<n; i++)
            scanf("%d",&value[i]);
        for (int i=0; i<n; i++)
            scanf("%d",&num[i]);
        memset(dp,-0x3f,sizeof(dp));
        dp[0] = 0;
        for (int i=0; i<n; i++)
        {
            MulPack(value[i], num[i]);
        }
        int sum=0;
        for (int i=1; i<=m; i++)
        {
            if (dp[i]>0)
                sum++;
        }
        printf("%d\n",sum);

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值