Hdu 2844 Coins

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14884    Accepted Submission(s): 5903

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

 

 

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

 

 

Output

For each test case output the answer on a single line.

 

 

Sample Input

3 10

1 2 4 2 1 1

2 5

1 4 2 1

0 0

 

 

Sample Output

8

4

#include<string.h>
#include<stdio.h>
int n,v;
int f[100050],val[105],amount[105];
void zeroOnePack(int cost,int weight)
{
    for(int i=v;i>=cost;i--)
        if(f[i-cost]+weight>f[i])
            f[i]=f[i-cost]+weight;
}
void completePack(int cost,int weight)
{
    for(int i=cost;i<=v;i++)
    if(f[i-cost]+weight>f[i])
            f[i]=f[i-cost]+weight;    
} 
void mutiplePack(int cost,int weight,int amount)
{
    if(cost*amount>=v)completePack(cost,weight);
    else
    {
        for(int k=1;k<amount;)
        {
            zeroOnePack(k*cost,k*weight);
            amount-=k;
            k=k*2;
        }
        zeroOnePack(amount*cost,amount*weight);
    }
}
int main()
{

    while(scanf("%d %d",&n,&v),n,v)
    {
        memset(f,0,sizeof(f));
        memset(val,0,sizeof(val));
        memset(amount,0,sizeof(amount));
        int sum=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(int j=1;j<=n;j++)
            scanf("%d",&amount[j]);
        for(int i=1;i<=n;i++)
            mutiplePack(val[i],val[i],amount[i]);
        for(int i=1;i<=v;i++)
            if(f[i]==i)
                sum++;
        printf("%d\n",sum);
    }
    return 0;
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值