HDU1671

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17853    Accepted Submission(s): 5957


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
题目的意思:给你几个号码,如果其中有一个号码完全是另一个号码的前缀,那这个号码就不可以拨出,否则可以。
思路:首先先检出字典树,之后要将它这个号码的尾部标记,这样在你找是否是前缀只需要找这个号码结束之后,是否有标记,其次还有可以比这串号码要长的也可以,就是判断它的下一个节点是否为空,不为空就代表这串数字是之前的一个号码的前缀,那么那个号码就不能拨出。最重要的是释放空间,每操作一次之后要清空树
#include<cstdio>
#include<iostream>
#include<cstring>
#include<stdlib.h>
using namespace std;
char num[15];
int flag=0;
struct node
{
    int end;
    node *next[10];
    node()
    {
        memset(next,NULL,sizeof(next));
        end=0;
    }
};
node *p,*root;
void insert()
{
    int i=0,t;
    p=root;
    while(num[i]!='\0')
    {
        t=num[i]-'0';
        if(p->next[t]==NULL)
            p->next[t]=new node();
        p=p->next[t];
        if(p->end)///判断这个号码是否已经出现过
        {
            flag=1;
        }
        i++;
    }
    p->end=1;
    for(int j=0;j<=9;j++)///查找这个号码是否是之前的某个号码的前缀
    {
        if(p->next[j])
        {
            flag=1;
            break;
        }
    }

}
void de(node *x)///清空
{
    if(x==NULL)
        return;
    for(int i=0;i<10;i++)
    {
        if(x->next[i]!=NULL)
            de(x->next[i]);
    }
    free(x);
    return;
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        flag=0;
        scanf("%d",&n);
        root=new node();
        while(n--)
        {
            scanf("%s",num);
            if(!flag)
                insert();
        }
        if(!flag)
            printf("YES\n");
        else
            printf("NO\n");
        de(root);

    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值