POJ 2955 括号匹配 Brackets (区间DP)

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5878 Accepted: 3137

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, imwhere 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source





import java.util.Arrays;
import java.util.Scanner;

public class Main {
	static final int maxn=105;
	static int[][] dp = new int[maxn][maxn];
	static String s;
	static boolean ok(int x,int y){
		char c = s.charAt(x-1);
		char cc = s.charAt(y-1);
		if(c=='[' && cc==']')return true;
		if(c=='(' && cc==')')return true;
		return false;
				
	}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in =  new Scanner(System.in);
		s  =in.nextLine();
		while(s.charAt(0)!='e'){
			
			for(int i=0;i<dp.length;i++){
				Arrays.fill(dp[i],0);
			}
			int n=s.length();
			for(int i=n;i>=1;i--){
				for(int j=1;j<=n;j++){
					if(i>j)dp[i][j]=0;
					else{
						if(ok(i,j)){
							dp[i][j]=Math.max(dp[i][j],dp[i+1][j-1]+2);
						}
						for(int k=i;k<j;k++)
							dp[i][j]=Math.max(dp[i][j], dp[i][k]+dp[k+1][j]);
					}
				}
			}
			System.out.println(dp[1][n]);
			s=in.nextLine();
			
		}
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值