poj 2309 BST

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

 

这也是一道很有意思的水题~

我发现第n层上(n=0,1,2……)的数字分别为2^n+2^(n+1)*k~由此就可以计算出每个数所在层数~

而根节点与最大数和最小数之间相差sigma 2^k- (k=0,1,2……n-1)~

所以代码如下~

#include"stdio.h"
int main()
{
 int n;
 int x;
 int i,j;
 int count;
 int lc,rc;
 int s;
 scanf("%d",&n);
 for(i=0;i<n;i++)
 {
  scanf("%d",&x);
  count=0;
  lc=rc=x;
  s=1;
  for(;;)
  {
   if(x%2!=0)
    break;
   x=x/2;
   count++;
  }
     for(j=0;j<count;j++)
  {
   lc=lc-s;
   rc=rc+s;
   s*=2;
  }
  printf("%d %d\n",lc,rc); 
 }
 return 0;
}

带看完discuss之后~我发现更简单的方法~利用树状数组思想中的位运算~

最小值就是该数用二进制表示后将其中的最后一个1挪到最后一位~

最大值就是将最后一个1后面全赋为1~

利用分别利用x-(x&(-x))+1和x+(x&(-x))-1就可以实现~

注意~(-x)表示将x取反后加1~

在位运算中还需注意~符号^是异或的意思~

下面是代码~要简洁许多~

 #include"stdio.h"
int main()
{
 int n;
 int x;
 scanf("%d",&n);
  while(n--)
  {
   scanf("%d",&x);
   printf("%d %d\n",x-(x&(-x))+1,x+(x&(-x))-1);
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值