POJ ACM习题【No.1862】

Stripies
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5363 Accepted: 2746

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

 

解题思路的关键在于:

最小的值是从大向小进行计算,可以使用不等式进行证明。

 

import java.util.*;
import java.text.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int num = Integer.valueOf(cin.nextLine()).intValue();
		List list = new ArrayList();
		
		for(int i = 0; i < num; i++)
			list.add(Double.valueOf(cin.nextLine()));
		
		Collections.sort(list);
		
		double result, temp = 0;
		double a, b = 0;
		
		if(list.size() == 1)
			result = Double.valueOf((Double)list.get(0)).doubleValue();
		else
		{
			int index = list.size() - 1;
			a = Double.valueOf((Double)list.get(index)).doubleValue();
			b = Double.valueOf((Double)list.get(index-1)).doubleValue();
			
			result = 2 * Math.sqrt(a * b);
			
			for(int i = index - 2; i>=0; i--)
			{
				a = Double.valueOf((Double)list.get(i)).doubleValue();
				result = 2 * Math.sqrt(a * result);
			}
		}
		
		DecimalFormat df = new DecimalFormat("#.000");
		System.out.println(df.format(result));
	}

}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值