问题 B: Rightmost Digit

题目描述

Given a positive integer N, you shouldoutput the most right digit of N^N. 

 

输入

The input contains several test cases. Thefirst line of the input is a single integer T which is the number of testcases. T test cases follow. 
Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

 

输出

For each test case, you should output therightmost digit of N^N. 

 

样例输入

2

3

4

样例输出

7

6


c:

#include<stdio.h>
int main()
{
	int n,i,b;
	int a[10][4]={{0,0,0,0},{1,1,1,1},{2,4,8,6},{3,9,7,1},{4,6,4,6},{5,5,5,5},{6,6,6,6},{7,9,3,1},{8,4,2,6},{9,1,9,1}};
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&b);
		int c,d;
		c=b%10;d=(b-1)%4;
		if(b%10==0) printf("0\n");
		else printf("%d\n",a[c][d]); 
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值