杭电oj 1001

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input


1 100


Sample Output


1 5050


 

#include <stdio.h>
int i,sum,n;
int main()
{
 //这题用公式做如果不作处理会数据溢出
 //题目中有这样一句话
 //You may assume the result will be in the range of 32-bit signed integer
 //虽然说结果在32位整型以内,但是公式是n*(n+1)/2
 //电脑在计算n*(n+1)的时候其实已经溢出了
 //因此可以作以下处理(1和2取其一即可)
 //1. 将 n 直接声明为   __int64 n;
 //2. 公式变为   n/2.0 * (n+1)
 while(scanf("%d",&n)!=EOF)
 {
  sum=0;
   for(i=1;i<=n;i++)
   {
    sum+=i;
   }
   printf("%d\n\n",sum);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值