poj 3259 Wormholes(spfa判断负环)

96 篇文章 0 订阅
44 篇文章 0 订阅


Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 43863 Accepted: 16107

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES


这道题只需判断有无负环就行,用spfa然后用cot数组记录每个点入队次数,次数如果大于N了说明有环,而这个题出现环的可能性一点是负环,所以此时return输出YES即可。

另外新学了一发正确的前向星,感觉比之前好用了,然后edg数组要开到5200以上,很奇怪题目说好的出现重复的边呢。我貌似把函数spfa里的数组开的过大re了,然后一直以为时edg开得不够,最后才发现函数里数组不能开得过大。

前向星用法:

void add(int u, int v, int w)
{
    edg[cnt].to=v;
    edg[cnt].w=w;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}


代码:


#include <iostream>
#include <cstdio>
using namespace std;
int book[505];
int head[505];
int cot[505];
int cnt;
int n,m,w;
struct p
{
    int to;
    int w;
    int next;
}edg[6005];
int dis[505];
int inf;
void add(int u, int v, int w)
{
    edg[cnt].to=v;
    edg[cnt].w=w;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}//前向星
int spfa(int s)
{
    int a[500000];
    int h,t;
    h=t=0;
    a[h]=s;
    dis[s]=0;
    book[s]=1;
    t++;
    while(h<t)
    {
        int x=a[h], k;
        book[x]=0;
        cot[x]++;
       if(cot[x]>=n)return 1; //判断有无环
        for(k=head[x]; k!=-1; k=edg[k].next)
        {
            if(dis[edg[k].to]>dis[x]+edg[k].w)
            {
                dis[edg[k].to]=dis[x]+edg[k].w;
                if(book[edg[k].to]==0)
            {
                book[edg[k].to]=1;
                a[t++]=edg[k].to;
            }
          }

        }h++;
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {

        scanf("%d%d%d", &n, &m, &w);
        int i, j;
        cnt=0;
        inf=99999999;
        for(i=1; i<=n; i++)//初始化
        {
            head[i]=-1;
            dis[i]=inf;
            book[i]=0;
            cot[i]=0;
        }
        for(i=0; i<m; i++)
        {
            int u,v,w;
            scanf("%d%d%d", &v, &u, &w);
            add(v, u, w);
            add(u, v, w);
        }
        for(i=0; i<w; i++)
        {
            int u,v,w;
            scanf("%d%d%d", &v, &u, &w);
            add(v, u, -w); //增加负边
        }

     if(spfa(1))printf("YES\n");
     else printf("NO\n");

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值