POJ - 1442




POJ - 1442
Black Box
Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %I64d & %I64u
 
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 


Let us examine a possible sequence of 11 transactions: 

Example 1 


N Transaction i Black Box contents after transaction Answer 
      (elements are arranged by non-descending)   


1 ADD(3)      0 3 
2 GET         1 3                                    3 
3 ADD(1)      1 1, 3 
4 GET         2 1, 3                                 3 
5 ADD(-4)     2 -4, 1, 3 
6 ADD(2)      2 -4, 1, 2, 3 
7 ADD(8)      2 -4, 1, 2, 3, 8 
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8 
9 GET         3 -1000, -4, 1, 2, 3, 8                1 
10 GET        4 -1000, -4, 1, 2, 3, 8                2 
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   


It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 



Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 


2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 


The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 



Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
Sample Output
3
3
1
2
Source

Northeastern Europe 1996


又是一道关于堆的题目

大致题意是输入一串数字在输入k个数字后(k即输入的第三行的每一个数)打印出目前第i个最小值
每次执行打印工作后i++


我的思路是建立一个最大堆 一个最小堆 打印过的元素insert到最大堆 新增元素在insert到最小堆之前先做检查

若该元素小于最大堆元素 则将最大堆顶元素insert到最小堆 并将新元素insert到最大堆

注意:由于我的insert操作每次都是在队尾或是heapdown返回pos处进行,所以进行打印insert工作之后 要把最小堆的末尾元素重新insert到最小堆顶heapdown 返回的pos 处 并将最小堆大小减一


AC代码如下

#include <stdio.h>
#include <stdlib.h>
void insert_min_h(int value,int pos);
void insert_max_h(int value,int pos);
void min_hup(int pos);
void max_hup(int pos);
int  min_hdown();
int  max_hdown();

int minheap[30000];
int maxheap[30000];
int max_hsize,min_hsize;

int main()
{
//    freopen("data.in","r",stdin);
//    freopen("data.out","w",stdout);
    int j,i,k,num_size,get_size,pos;
    int num[30000],get[30000];

    scanf("%d%d",&num_size,&get_size);
    for(j=0;j<num_size;j++) scanf("%d",num+j);
    for(j=0;j<get_size;j++) scanf("%d",get+j);

    i = 0;  k = 0;
    while(max_hsize<get_size)
    {
        if(get[i]==k)           //k means the number of elements that has been inserted
        {
            printf("%d\n",minheap[1]);
            insert_max_h(minheap[1],max_hsize+1);    //max heap size should always be equal with i
            pos = min_hdown();
            insert_min_h(minheap[min_hsize],pos);
            min_hsize--;
            max_hsize++;
            i++;
        }
        else
        {
            if(i>0&&num[k]<maxheap[1])
            {
                insert_min_h(maxheap[1],min_hsize+1);
                pos = max_hdown();
                insert_max_h(num[k],pos);
                min_hsize++;
                k++;
                continue;
            }

            insert_min_h(num[k],min_hsize+1);
            min_hsize++;
            k++;
        }
    }
    return 0;
}

void insert_min_h(int value,int pos)
{
    minheap[pos] = value;
    min_hup(pos);
}

void insert_max_h(int value,int pos)
{
    maxheap[pos] = value;
    max_hup(pos);
}

void min_hup(int pos)
{
    int q,temp;
    q = pos/2;
    while(q>0)
    {
        if(minheap[pos]<minheap[q])
        {
            temp = minheap[pos];
            minheap[pos] = minheap[q];
            minheap[q] = temp;
            pos = q;
            q = pos/2;
        }
        else
            break;
    }
}

void max_hup(int pos)
{
    int q,temp;
    q = pos/2;
    while(q>0)
    {
        if(maxheap[pos]>maxheap[q])
        {
            temp = maxheap[pos];
            maxheap[pos] = maxheap[q];
            maxheap[q] = temp;
            pos = q;
            q = pos/2;
        }
        else
            break;
    }
}

int min_hdown()
{
    int q=1;
    while(2*q<=min_hsize)
    {
        int left,right;
        left = 2*q;
        right= 2*q+1;
        if(right>min_hsize||minheap[right]>minheap[left])
        {
            minheap[q] = minheap[left];
            q = left;
        }
        else
        {
            minheap[q] = minheap[right];
            q = right;
        }
    }
    return q;
}

int max_hdown()
{
    int q=1;
    while(2*q<=max_hsize)
    {
        int left,right;
        left = 2*q;
        right= 2*q+1;
        if(right>max_hsize||maxheap[right]<maxheap[left])
        {
            maxheap[q] = maxheap[left];
            q = left;
        }
        else
        {
            maxheap[q] = maxheap[right];
            q = right;
        }
    }
    return q;
}



不过.写的比较麻烦 接下来要补习C++和算法函数库的知识啊..

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值