甲级PAT 1031 Hello World for U (20 分)(图形输出)

1031 Hello World for U (20 分)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题目要求: 

给出一个长度不小于5,不超过80的字符串(不包含空格),按字符串的顺序输出为U型。U型左边一竖包含n1个字符,下边为n2个字符,右边一竖为n3个字符。n1 + n2 + n3 - 2 = N;这里表示左边和右边一竖均包含在底部的字符。所以会多出两个字符。

这三个边的关系限制是 n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } ,即找出最接近n2的最大的竖边长度

解题思路:

n1 + n2 + n3 = N + 2;  n1 和 n3相等,2 * n1 + n2 = N + 2; 要找出满足条件的最大的n1,即三边之和尽可能的满足均分。多的给底边n2。正好在c/c++中的除法运算会舍弃小数部分。n1 = (N + 2)/3,底边 n2 = (N+2) - 2 * n1;

接下来就是按格式输出就可以了。

完整代码:

#include<bits/stdc++.h>
using namespace std;

int main(){
	int i,j,n1,n2,l;
	string s;
	cin>>s;
	l = s.length();
	n1 = (l + 2) / 3;
	n2 = l + 2 - 2 * n1;
	for(i = 1; i < n1; i++){
		cout<<s[i-1];
		for(j = 1; j <= n2 - 2; j++) cout<<" ";
		cout<<s[l-i]<<endl;
	} 
	for(;i < n1+n2; i++) cout<<s[i-1];
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值