甲级 PAT1146 Topological Order (25 分)(拓扑排序)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目要求 

给出一个有向图,根据这个有向图判断给出的拓扑序列中哪些不正确,下标从0开始

解题思路

在输入图的时候统计每个结点的入度,如果是拓扑序列,则从第一个结点开始,将第一个结点所能到达的所有结点入度减一,统计入度为0的个数。如果入度为0的个数与结点数相等则是拓扑序列。

完整代码

#include<bits/stdc++.h>
using namespace std;

vector<int> G[1010],a,indegree,tindegree,ans;
int n;

bool topsort(){
	int num=0,i,j;
	for(i=1;i<=n;i++){
		int u=a[i];
		if(tindegree[u]==0) num++;
		for(j=0;j<G[u].size();j++){
			int v=G[u][j];
			tindegree[v]--;
		}
	}
	if(num==n) return true;
	else return false;	
}

int main(){
	int m,k,u,v,i,j;
	cin>>n>>m;
	a.resize(n+1);
	indegree.resize(n+1);
	tindegree.resize(n+1);
	for(i=0;i<m;i++){
		cin>>u>>v;
		G[u].push_back(v);
		indegree[v]++;
	} 
	cin>>k;
	for(j=0;j<k;j++){
		a.clear();
		tindegree=indegree;
		for(i=1;i<=n;i++){
			cin>>a[i];
		}
		if(!topsort()) ans.push_back(j);
	}
	for(i=0;i<ans.size();i++){
		if(i!=0) cout<<" ";
		cout<<ans[i];
	}
	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值