PAT真题练习(甲级)1146 Topological Order (25 分)

PAT真题练习(甲级)1146 Topological Order (25 分)

原题网址:https://pintia.cn/problem-sets/994805342720868352/problems/994805343043829760

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input :

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output :

3 4

思路 :

拓扑排序:指将有向无环图G中所有顶点排成一个线性序列,满足对于任意边(u,v)∈E(G),点u在点v之前。
因此,在本题中我们只需要判断每个点的后面存不存在该点的先驱点即可。

AC代码

#include <stdio.h>
#include <iostream>
#include <vector>
#include <set>
#include <math.h>
using namespace std;

int main() {
	int N, M;
	cin >> N >> M;
	// 用set存储点v的所有前驱点
	vector<set<int>> parents(N + 1);
	int v1, v2;
	for (auto i = 1; i <= M; i++) {
		cin >> v1 >> v2;
		parents[v2].insert(v1);
	}

	int K;
	cin >> K;
	vector<int> result;
	for (auto t = 0; t < K;t++) {
		vector<int> order(N);
		for (auto i = 0; i < N; i++) {
			cin >> order[i];
		}
		int flag = true;
		for (auto i = 0; i < N;i++) {
			// 若该点没有前驱点,则返回
			if (parents[order[i]].size() == 0) continue;
			// 否则遍历读入顺序中,该点之后的所有点
			// 若含有该点的前驱点,则说明不是拓扑排序,flag== false 跳出循环
			for (auto j = i + 1; j < N;j++) {
				if (parents[order[i]].find(order[j]) != parents[order[i]].end()) {
					flag = false;
					break;
				}
			}
			if (!flag) break;
		}
		// 存入不是拓扑排序的序号
		if (!flag) result.push_back(t);
	}

	for (auto i = 0; i < result.size();i++) {
		if (i != 0) cout << " ";
		cout << result[i];
	}
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值