Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4
3
17 4
19 4
18 5
0
Sample Output
Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414
题意:第一个数v为顶点的数目,第2行到第v+1行是坐标,起点是第一行,终点是第二行。各点的距离需要自己求。各个点之间都是相通的。就相当于是完全图了。
解题思路:这个道题准确的来说不是最短路,也不是最小生成树,定义 f(i,j)为i->j的路径上的最大跳的最小值,
那么f(i,j)=min( f(i,j), max(f(i,k),f(k,j)) )
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const int MAXN = 205;
const int INF = 0x3f3f3f3f;
struct Edge{ //每个点的坐标
int from;
int to;
}edge[MAXN];
double cost[MAXN][MAXN];
int v; //顶点数
void dijkstra(int s)
{
bool used[MAXN]; //true: 顶点可用,false: 顶点不可用
double dis[MAXN]; //dis[j]为从一号石头到第j号石头最短路中的最大边
memset(dis, INF, sizeof(dis));
memset(used, true, sizeof(used));
// for (int i = 0; i < v; i++) {
// dis[i] = cost[0][i];
// }
dis[s] = 0;
used[s] = false;
while (true) {
int k = -1;
for (int i = 0; i < v; i++) {
if (used[i] && (k == -1 || dis[k] > dis[i])) {
k = i;
}
}
if (k == -1) {
break;
}
used[k] = false;
for (int i = 0; i < v; i++) {
dis[i] = min(dis[i], max(dis[k], cost[k][i])); //最短路中的最大边
}
}
printf("Frog Distance = %.3f\n\n", dis[1]);
}
int main()
{
int caseNum = 1;
while(scanf("%d", &v) && v) {
memset(cost, INF, sizeof(cost));
double x[2], y[2]; //坐标
for (int i = 0; i < v; i++) {
scanf("%d%d", &edge[i].from, &edge[i].to);
}
for (int i = 0; i < v; i++) {
for (int j = i + 1; j < v; j++) {
cost[j][i] = cost[i][j] = sqrt(pow(edge[i].from - edge[j].from, 2)
+ pow(edge[i].to - edge[j].to, 2)); //pow 次方,sqrt都是头文件都是cmath
}
}
printf("Scenario #%d\n", caseNum++);
dijkstra(0);
}
return 0;
}
//ps:poj这道题,输出是要用%f. 因为G++ double 输出就是%f