hdu-1865-1sting(大数问题)


1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3870    Accepted Submission(s): 1463



Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1133 2100 1297 1866 1868 

按字符串长度递推,然后2的n次方是个大数

/*
 * http://acm.hdu.edu.cn/showproblem.php?pid=1865
 * by jtahstu on 2015/3/31 14:00
 */
package 大数;

import java.math.BigInteger;
import java.util.Scanner;

public class HDU1865 {
	public static Scanner cin = new Scanner(System.in);

	public static void main(String[] args) {
		// TODO 自动生成的方法存根
		int n = cin.nextInt();
		BigInteger a[] = new BigInteger[201];
		a[1] = BigInteger.valueOf(1);
		a[2] = BigInteger.valueOf(2);
		for (int i = 3; i <= 200; i++)
			a[i] = a[i - 1].add(a[i - 2]);//递推,只是这是大数
		while (n-- > 0) {
			String s;
			s = cin.next();
			int len = s.length();
			System.out.println(a[len]);

		}
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值