素数求和问题
Time Limit:1000MS Memory Limit:65536K
Total Submit:245 Accepted:160
Description
现在给你N个数现在要求你写出一个程序,找出这N个数中的所有素数,并求和。
Input
第一行给出整数M(0每组测试数据第一行给你N,代表该组测试数据的数量。
接下来的N个数为要测试的数据,每个数小于1000
Output
每组测试数据结果占一行,输出给出的测试数据的所有素数和
Sample Input
3
5
1 2 3 4 5
8
11 12 13 14 15 16 17 18
10
21 22 23 24 25 26 27 28 29 30
Sample Output
10
41
52
Source
nyist
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1031 {
class Program {
static bool prime(int n) {
if (n == 1) return false;
if (n == 2) return true;
for (int i = 2; i * i <= n; i++)
if (n % i == 0)
return false;
return true;
}
static void Main(string[] args) {
int n = int.Parse(Console.ReadLine());
while (n-- > 0) {
int m = int.Parse(Console.ReadLine());
string[] s = Console.ReadLine().Split();
int sum = 0;
for (int i = 0; i < m; i++)
if (prime(int.Parse(s[i])))
sum += int.Parse(s[i]);
Console.WriteLine(sum);
}
//Console.ReadLine();
}
}
}