1041 -- 找零钱

找零钱

Time Limit:1000MS  Memory Limit:65536K
Total Submit:246 Accepted:174

Description

在售货员向顾客找零钱时,一般都是尽可能找最少数量的钱币给顾客。下面将给出一定数额的人民币,请将其分解为数量最少的货币。货币单位仅有100 50 20 10 5 2 1几个币种。

Input

一个整数,即人民币总额(单位元)

Output

分解后的人民币序列,用回车分隔

Sample Input

19

Sample Output

10
5
2
2

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1041 {
        /// <summary>
        /// 哈哈,这个方法就问你6不6
        /// </summary>
        class Program {
            static void Main(string[] args) {
                int n = int.Parse(Console.ReadLine());
                int x1, x2, x3, x4, x5, x6, x7;
                x1 = n / 100;
                n = n % 100;
                x2 = n / 50;
                n = n % 50;
                x3 = n / 20;
                n = n % 20;
                x4 = n / 10;
                n = n % 10;
                x5 = n / 5;
                n = n % 5;
                x6 = n / 2;
                n = n % 2;
                x7 = n;
                for (int i = 0; i < x1; i++)
                    Console.WriteLine("100");
                for (int i = 0; i < x2; i++)
                    Console.WriteLine("50");
                for (int i = 0; i < x3; i++)
                    Console.WriteLine("20");
                for (int i = 0; i < x4; i++)
                    Console.WriteLine("10");
                for (int i = 0; i < x5; i++)
                    Console.WriteLine("5");
                for (int i = 0; i < x6; i++)
                    Console.WriteLine("2");
                for (int i = 0; i < x7; i++)
                    Console.WriteLine("1");
            }
        }
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值