1045 -- 删除重复

删除重复

Time Limit:1000MS  Memory Limit:65536K
Total Submit:326 Accepted:206

Description

在一无符号整型数组中,存在着一些重复的数字,请将重复的数字去掉,再按升序进行输出。

Input

输入数据由两行组成,第一行为数字的数量,第二行则是由空格分隔的数据。

Output

由回车分隔的若干数据。

Sample Input

5
1 1 6 3 3

Sample Output

1
3
6

Hint

(注:待处理的数据不超过200个,且所有数据都为[0,10000]之间的自然数。)

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1045 {
        class Program {
            static void Main(string[] args) {
                int n = int.Parse(Console.ReadLine());
                string[] s = Console.ReadLine().Split();
                int[] a = new int[210];
                for (int i = 0; i < n; i++)
                    a[i] = int.Parse(s[i]);
                Array.Sort(a, 0, n);
                Console.WriteLine(a[0]);
                for (int i = 1; i < n; i++)
                    if (a[i] != a[i - 1])
                        Console.WriteLine(a[i]);
                //Console.ReadLine();
            }
        }
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值