1078 -- n-1位数

n-1位数

Time Limit:1000MS  Memory Limit:65536K
Total Submit:188 Accepted:113

Description

已知w是一个大于10但不大于1000000的无符号整数,若w是n(n ≥ 2)位的整数,则求出w的后n-1位的数。

Input

第一行为M,表示测试数据组数。
接下来M行,每行包含一个测试数据。

Output

输出M行,每行为对应行的n-1位数(忽略前缀0)。如果除了最高位外,其余位都为0,则输出0。

Sample Input

4
1023
5923
923
1000

Sample Output

23
923
23
0

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1078 {
        class Program {
            static void Main(string[] args) {
                int n = int.Parse(Console.ReadLine());
                while (n-- > 0) {
                    string sb = Console.ReadLine();
                    int ans = int.Parse(sb) - (int)Math.Pow(10.0, sb.Length - 1) * (sb[0] - '0');
                    Console.WriteLine(ans);
                }
            }
        }
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值