1136 -- 敲7

敲7

Time Limit:1000MS  Memory Limit:65536K
Total Submit:444 Accepted:219

Description

description:

输出7和7的倍数,还有包含7的数字例如(17,27,37...70,71,72,73...)

Input

input

一个整数N。(N不大于3000)

Output

output

从小到大排列的不大于N的与7有关的数字,每行一个。

Sample Input

20

Sample Output

7
14
17

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1136 {
        class Program {
            static void Main(string[] args) {
                int n = int.Parse(Console.ReadLine());
                for (int i = 1; i <= n; i++) {
                    if (i % 7 == 0 || i % 10 == 7 || i / 10 % 10 == 7 || i / 100 % 10 == 7)
                        Console.WriteLine(i);
                }
            }
        }
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值