1141 -- n%m

n%m

Time Limit:1000MS  Memory Limit:65536K
Total Submit:313 Accepted:193

Description

求 1%m+2%m+3%m...+n%m的值。

Input

第一行有一个整数N表示有N组测试数据。
每组测试数据都有两个整数n,m( 0< n < 2^20 且 0 < m < 2014)

Output

求出每组 1%m+2%m+3%m...+n%m 的值。

Sample Input

2
3 2
63152 373

Sample Output

2
11731552

Hint

ahstu@icpc2014

Source

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    namespace AK1141 {
        class Program {
            static void Main(string[] args) {
                int t = int.Parse(Console.ReadLine());
                while (t-- > 0) {
                    string[] a = Console.ReadLine().Split();
                    long n = long.Parse(a[0]), m = long.Parse(a[1]);
                    long sum = 0;
                    for (int i = 1; i <= n; i++)
                        sum += i % m;
                    Console.WriteLine(sum);
                }
            }
        }
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值