正三角形的外接圆面积
Time Limit:1000MS Memory Limit:65536K
Total Submit:184 Accepted:124
Description
给你正三角形的边长,pi=3.1415926 ,求正三角形的外接圆面积。
Input
只有一组测试数据 第一行输入一个整数n ( 1 < n < 1000 ) 表示接下来要输入n个边长m (1.0 <= m < 1000.0)
Output
输出每个正三角形的外接圆面积,保留两位小数,每个面积单独占一行。
Sample Input
5
1
13
22
62
155
Sample Output
1.05
176.98
506.84
4025.43
25158.92
Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace AK1174 {
class Program {
static void Main(string[] args) {
int n = int.Parse(Console.ReadLine());
while (n-- > 0) {
int a = int.Parse(Console.ReadLine());
double pi = 3.1415926;
double sb = a * a * pi / 3;
Console.WriteLine(sb.ToString("0.00"));
}
}
}
}