UVA 437 The Tower of Babylon

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions tex2html_wrap_inline32 . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values tex2html_wrap_inline40 , tex2html_wrap_inline42 and tex2html_wrap_inline44 .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Casecase: maximum height =height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28

Case 4: maximum height = 342

最长上升子序列变形,把每个长方体都拆成六个即可。

#include<iostream>  
#include<algorithm>
#include<math.h>
#include<cstdio>
#include<string>
using namespace std;
const int maxn = 50;
int n, f[6 * maxn], i, j, a[6 * maxn][3], tot, sum;

int cmp(int *x, int*y)
{
	if (x[0] == y[0])	return x[1] - y[1];
	else return x[0] - y[0];
}

int main(){
	int t = 0;
	while (cin >> n, n)
	{
		for (tot = 0, i = 0; i < n; i++)
		{
			int x, y, z;	cin >> x >> y >> z;
			a[tot][0] = x; a[tot][1] = y; a[tot++][2] = z;
			a[tot][0] = x; a[tot][1] = z; a[tot++][2] = y;
			a[tot][0] = y; a[tot][1] = x; a[tot++][2] = z;
			a[tot][0] = y; a[tot][1] = z; a[tot++][2] = x;
			a[tot][0] = z; a[tot][1] = x; a[tot++][2] = y;
			a[tot][0] = z; a[tot][1] = y; a[tot++][2] = x;
		}
		for (i = 0; i < tot; i++)
			for (j = i + 1; j < tot; j++)
				if (cmp(a[i], a[j])>0)	swap(a[i], a[j]);
		for (i = 0; i < tot; i++) f[i] = a[i][2];
		for (i = 0; i < tot; i++)
			for (j = 0; j < i; j++)
				if (a[i][0]>a[j][0] && a[i][1]>a[j][1]) f[i] = max(f[i], f[j] + a[i][2]);
		for (sum = 0, i = 0; i < tot; i++) sum = max(sum, f[i]);
		printf("Case %d: maximum height = %d\n", ++t, sum);
	}
	return 0;
}

嘛~,也可以当做是图(DAG)上的最长路处理。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值