【Jason's_ACM_解题报告】The Tower of Babylon

The Tower of Babylon 

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:


The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi,yi,zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.


Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.


Input and Output
The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values  xi ,  yi and zi .


Input is terminated by a value of zero (0) for n.


For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"


Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342


此题拿到手,我瞬间想到了嵌套矩形,这是一个纯粹的嵌套矩形的变形,首先,巴比伦塔的每一层是严格递增的所以可以看作是一个DAG(有向无环图),而每一种砖块是无穷多个的,所以我们可以把每个砖块看作三个带有权值的矩形,例如(10,20,30)可以看作(10,20)权值为30,(10,30)权值20,(20,30)权值10的三个矩形,然后求有向无环图的最长路。

当然这道题还有其他的求解方式,其一是求出所有矩形,并按照权值排序,并求最长上升子序列。其二是Liu所讨论的方法,其实Liu的方法与我介绍的方法并无二致,只是在对状态的处理上有一点出入而已,此处不作说明。



附代码如下:

嵌套矩形变形:

#include<cstdio>
#include<cstring>

#include<algorithm>

using namespace std;

#define MAXN (30+5)

struct EDGE{
	int L,W,H;//长宽高 
};

int n,total;
int d[MAXN*3];
bool G[MAXN*3][MAXN*3];
EDGE e[MAXN*3];


void creat(int x,int y,int z) {
	e[total++]=(EDGE){x,y,z};
	e[total++]=(EDGE){y,z,x};
	e[total++]=(EDGE){x,z,y};
}

bool check(int x,int y){
	return e[x].L<e[y].L&&e[x].W<e[y].W;
}

int dp(int u){
	int& ans=d[u];
	if(ans>-1)return ans;
	ans=0;
	for(int v=0;v<total;v++){
		if(G[u][v])ans=max(ans,dp(v)+e[v].H);
	}
	return ans;
}

int main(){
	int K=0;
	while(scanf("%d",&n)==1&&n){
		total=0;
		for(int i=0;i<n;i++){
			int a[3];
			scanf("%d%d%d",&a[0],&a[1],&a[2]);
			sort(a,a+3);
			creat(a[0],a[1],a[2]);
		}
		
		memset(G,false,sizeof(G));
		for(int i=0;i<total;i++){
			for(int j=0;j<total;j++){
				if(check(i,j))G[i][j]=true;
			}
		}
		
		int ans=0;
		for(int i=0;i<total;i++){
			memset(d,-1,sizeof(d));
			ans=max(ans,dp(i)+e[i].H);
		}
		printf("Case %d: maximum height = %d\n",++K,ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值