HDU 3450 Counting Sequences

52 篇文章 0 订阅
35 篇文章 0 订阅

Problem Description

For a set of sequences of integers{a1,a2,a3,...an}, we define a sequence{ai1,ai2,ai3...aik}in which 1<=i1<i2<i3<...<ik<=n, as the sub-sequence of {a1,a2,a3,...an}. It is quite obvious that a sequence with the length n has 2^n sub-sequences. And for a sub-sequence{ai1,ai2,ai3...aik},if it matches the following qualities: k >= 2, and the neighboring 2 elements have the difference not larger than d, it will be defined as a Perfect Sub-sequence. Now given an integer sequence, calculate the number of its perfect sub-sequence.

Input

Multiple test cases The first line will contain 2 integers n, d(2<=n<=100000,1<=d=<=10000000) The second line n integers, representing the suquence

Output

The number of Perfect Sub-sequences mod 9901

Sample Input

4 2
1 3 7 5

Sample Output

4


统计数组中的完美子序列,相邻元素差不大于d的是完美子序列。

对原数组进行排序,当前加入的数字为x,则只对接下来出现的在【x-d,x+d】范围内的数有影响。

使用线段树或树状数组统计皆可。

#include<iostream>  
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 100005;
const int base = 9901;
int n, f[4 * maxn], M, d, a[maxn], b[maxn], ans;

int sum(int x)
{
	int tot = 0;
	for (x += M; x; x >>= 1) tot = (tot + f[x]) % base;
	return tot;
}

void add(int l, int r, int y)
{
	for (l += M - 1, r += M + 1; l ^ r ^ 1; l >>= 1, r >>= 1)
	{
		if (~l & 1) f[l ^ 1] += y;
		if ( r & 1) f[r ^ 1] += y;
	}
}

int main()
{
	while (~scanf("%d%d", &n, &d))
	{
		for (ans = 0, M = 1; M < n; M += M);
		memset(f, 0, sizeof(f));
		for (int i = 1; i <= n; b[i] = a[i++]) scanf("%d", &a[i]);
		sort(b + 1, b + n + 1);
		for (int i = 1; i <=n; i++)
		{
			int l = a[i] - d, r = a[i] + d, x = a[i];
			l = lower_bound(b + 1, b + n + 1, l) - b;
			r = upper_bound(b + 1, b + n + 1, r) - b - 1;
			x = lower_bound(b + 1, b + n + 1, x) - b;
			ans += x = sum(x);	ans %= base;
			add(l, r, x + 1);
		}
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值