HDU 5204 Rikka with sequence

61 篇文章 0 订阅


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


Yuta have a sequence. Because the sequence is very self-willed(RenXing), at first the sequence is empty. And then Yuta do n operations on this sequence, each operation is either of these two types:


1.Add a number w into each gap of the sequence. For example if w=3 and the sequence before is “2 4”, it will be changed to “3 2 3 4 3”.
**after the first operation of the first type, there is only one number in the sequence**


2.Query the kth small number in the subsequence [L,R]. For example if k=2, L=2, R=4 and the sequence is “3 2 3 4 2”, the answer will be 3.


Yuta wants Rikka to tell him the answer of each query.


It is too difficult for Rikka. Can you help her?
 

Input
The first line contains one number  n(n100000) . Each of the following  n  lines describes an operation: if it is “1 w” it will be the first type. Otherwise if it is “2 L R k”, it will be the second type.  (1w109,LR1018)
R will not be larger than the length of the sequence
 

Output
For each query operation, output one number – the answer.
 

Sample Input
  
  
6 1 3 1 1 2 2 3 2 1 2 2 3 5 2 2 1 4 4
 

Sample Output
  
  
3 2 3
因为每次加进来的数一定占据了当前的奇数位置,所以暴力的统计区间范围内的数字个数即可。
#include <cstdio>
#include <algorithm>
const int maxn = 200009;
using namespace std;
int n, a[maxn], m, tot;
long long L, R, l, r, K;

struct node
{
    int w;
    long long cnt;
    node(int w = 0, long long cnt = 0) :w(w), cnt(cnt){}
    bool operator<(const node &rhs)const{ return w < rhs.w; }
}p[maxn];

inline void solve()
{
    scanf("%I64d%I64d%I64d", &L, &R, &K);
    int time = 0;
    for (int t = tot - 1; L <= R; L = (L + 1) >>1, R = R >> 1, t--)
    {
        l = L; if (!(l & 1))l++;
        r = R; if (!(r & 1))r--;
        if (l <= r) p[time++] = node(a[t], (r - l) / 2 + 1);            
    }
    sort(p, p + time);
    for (int i = 0; K&&i < tot; i++)
    {
        K -= min(K, p[i].cnt);            
        if (!K) printf("%d\n", p[i].w);
    } 
}

int main()
{
    while (scanf("%d", &n) != EOF)
    {
        tot = 0;
        while (n--)
        {
            scanf("%d", &m);
            if (m == 1) scanf("%d", &a[tot++]);
            else solve();
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值