HDU 3374 String Problem

9 篇文章 0 订阅
2 篇文章 0 订阅

Problem Description

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank 
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6

1 3 2 3

最小表示法求出位置,然后kmp求循环节。

表示之前完全不知道有最小表示法这样的东西,推荐看看百度文库里的ppt

差不多可以理解,最大表示法其实就是比较的时候反一下。

具体看代码。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1000001;
int n, nt[maxn], N;
char s[maxn];

void getnext()
{
	nt[0] = -1;
	for (int i = 0, j; s[i]; i++)
	{
		j = nt[i];
		while (j >= 0 && s[i] != s[j]) j = nt[j];
		nt[i + 1] = j + 1;
	}
}

int cmp(int x, char a, char b)
{
	if (a > b) return x - 0;
	if (a < b) return 1 - x;
	return 2;
}

int present(int z)
{
	int i, j, k, x, y;
	for (i = 0, j = 1, k = 0; k < n;)
	{
		if (i == j) { j++; k = 0; }
		x = (i + k) % n;	y = (j + k) % n;
		switch (cmp(z, s[x], s[y]))
		{
			case 0:i += k + 1; k = 0; break;
			case 1:j += k + 1; k = 0; break;
			case 2:k++; break;
		}
	}
	return min(i, j);
}

int main()
{
	while (~scanf("%s", s))
	{
		n = strlen(s);
		getnext();
		N = n / (n - nt[n]);
		printf("%d %d %d %d\n", present(0) + 1, N, present(1) + 1, N);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值