HDU 5432 Pyramid Split

21 篇文章 0 订阅
Problem Description
Xiao Ming is a citizen who's good at playing,he has lot's of gold cones which have square undersides,let's call them pyramids.

Anyone of them can be defined by the square's length and the height,called them width and height.

To easily understand,all the units are mile.Now Ming has  n  pyramids,there height and width are known,Xiao Ming wants to make them again to get two objects with the same volume.

Of course he won't simply melt his pyramids and distribute to two parts.He has a sword named "Tu Long" which can cut anything easily.

Now he put all pyramids on the ground (the usdersides close the ground)and cut a plane which is parallel with the water level by his sword ,call this plane cutting plane.

Our mission is to find a cutting plane that makes the sum of volume above the plane same as the below,and this plane is average cutting plane.Figure out the height of average cutting plane.
 

Input
First line:  T , the number of testcases. (1T100)

Then  T  testcases follow.In each testcase print three lines :

The first line contains one integers  n(1n10000) , the number of operations.

The second line contains  n  integers  A1,,An(1in,1Ai1000)  represent the height of the  ith  pyramid.



The third line contains  n  integers  B1,,Bn(1in,1Bi100)  represent the width of the  ith  pyramid.
 

Output
For each testcase print a integer - **the height of average cutting plane**.

(the results take the integer part,like 15.8 you should output 15)
 

Sample Input
  
  
2 2 6 5 10 7 8 702 983 144 268 732 166 247 569 20 37 51 61 39 5 79 99
 

Sample Output
  
  
1

98

二分

#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 100005;
int T, n, m;
double a[maxn], b[maxn];

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        for (int i = 1; i <= n; i++) scanf("%lf", &a[i]);
        for (int i = 1; i <= n; i++) scanf("%lf", &b[i]);
        double l, r, mid;
        for (l = 0, r = 1000; l + 1e-2 < r;)
        {
            mid = (l + r) / 2;
            double v1 = 0, v2 = 0, v;
            for (int i = 1; i <= n; i++)
            {
                if (a[i] >= mid)
                {
                    v = (a[i] - mid) / a[i] * b[i];
                    v = v*v*(a[i] - mid) / 3;
                    v1 += v;
                    v2 += a[i] * b[i] * b[i] / 3 - v;
                }
                else v2 += a[i] * b[i] * b[i] / 3;
            }
            if (v1 > v2) l = mid; else r = mid;
        }
        int ans = l;
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值