POJ 1741 Tree

Description

Give a tree with n vertices,each edge has a length(positive integer less than 1001). 
Define dist(u,v)=The min distance between node u and v. 
Give an integer k,for every pair (u,v) of vertices is called valid if and only if dist(u,v) not exceed k. 
Write a program that will count how many pairs which are valid for a given tree. 

Input

The input contains several test cases. The first line of each test case contains two integers n, k. (n<=10000) The following n-1 lines each contains three integers u,v,l, which means there is an edge between node u and v of length l. 
The last test case is followed by two zeros. 

Output

For each test case output the answer on a single line.

Sample Input

5 4
1 2 3
1 3 1
1 4 2
3 5 1
0 0

Sample Output

8

树上点分治,入门级题目,最近决定开始搞树上的问题了。先拿这个练练手。

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef unsigned long long LL;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int n, m, x, y, z;
int ft[maxn], nt[maxn], u[maxn], v[maxn], sz;
int vis[maxn], cnt[maxn], mx[maxn], dis[maxn], tot;

void AddEdge(int x, int y, int z)
{
	u[sz] = y;	v[sz] = z; nt[sz] = ft[x]; ft[x] = sz++;
}

void clear(int x)
{
	sz = 0;	mx[0] = INF;
	for (int i = 1; i <= x; i++)
	{
		ft[i] = -1;	vis[i] = 0;
	}
}

int dfs(int x, int fa, int sum)
{
	int ans = 0;
	cnt[x] = 1;	 mx[x] = 0;
	for (int i = ft[x]; i != -1; i = nt[i])
	{
		if (u[i] == fa || vis[u[i]]) continue;
		int k = dfs(u[i], x, sum);
		cnt[x] += cnt[u[i]];
		mx[x] = max(mx[x], cnt[u[i]]);
		if (mx[k] < mx[ans]) ans = k;
	}
	mx[x] = max(mx[x], sum - cnt[x]);
	return mx[x] < mx[ans] ? x : ans;
}

void dfsdis(int x, int fa, int len)
{
	dis[tot++] = len;
	for (int i = ft[x]; i != -1; i = nt[i])
	{
		if (vis[u[i]] || u[i] == fa) continue;
		dfsdis(u[i], x, len + v[i]);
	}
}

int find(int x, int len)
{
	tot = 0;  
	dfsdis(x, -1, len);
	sort(dis, dis + tot);
	int ans = 0;
	for (int i = 0, j = tot - 1; i < tot; i++)
	{
		while (j >= 0 && dis[i] + dis[j] > m) j--;
		if (i < j) ans += j - i; else break;
	}
	return ans;
}

int solve(int x, int sum)
{
	int y = dfs(x, -1, sum), ans = find(y, 0);
	vis[y] = 1;
	for (int i = ft[y]; i != -1; i = nt[i])
	{
		if (!vis[u[i]])
		{
			ans -= find(u[i], v[i]);
			if (cnt[u[i]] < cnt[y]) ans += solve(u[i], cnt[u[i]]);
			else ans += solve(u[i], sum - cnt[y]);
		}
	}
	return ans;
}

int main()
{
	while (scanf("%d%d", &n, &m), n + m)
	{
		clear(n);
		for (int i = 1; i < n; i++)
		{
			scanf("%d%d%d", &x, &y, &z);
			AddEdge(x, y, z);
			AddEdge(y, x, z);
		}
		printf("%d\n", solve(1, n));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值