HDU 5687 Problem C

Problem Description
度熊手上有一本神奇的字典,你可以在它里面做如下三个操作:

  1、insert : 往神奇字典中插入一个单词

  2、delete: 在神奇字典中删除所有前缀等于给定字符串的单词

  3、search: 查询是否在神奇字典中有一个字符串的前缀等于给定的字符串
 

Input
这里仅有一组测试数据。第一行输入一个正整数 N(1N100000) ,代表度熊对于字典的操作次数,接下来 N 行,每行包含两个字符串,中间中用空格隔开。第一个字符串代表了相关的操作(包括: insert, delete 或者 search)。第二个字符串代表了相关操作后指定的那个字符串,第二个字符串的长度不会超过30。第二个字符串仅由小写字母组成。
 

Output
对于每一个search 操作,如果在度熊的字典中存在给定的字符串为前缀的单词,则输出Yes 否则输出 No。
 

Sample Input
  
  
5 insert hello insert hehe search h delete he search hello
 

Sample Output
  
  
Yes No

字典树的插入和删除以及查询操作,每个点开个count统计有多少条字符串,此题容易爆内存。

#include<cstdio>
#include<string>
#include<map>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 50;
const int maxp = 3e6 + 5;
char s[maxn], x[maxn];
int n, tot, cnt[maxp];
int f[maxp][26];

int main()
{
    while (scanf("%d", &n) != EOF)
    {
        tot = 1; cnt[1] = 0; memset(f[0], 0, sizeof(f[0]));
        while (n--)
        {
            scanf("%s%s", s, x);
            if (s[0] == 'i')
            {
                int rt = 1;
                for (int i = 0,j; x[i]; i++)
                {
                    j = x[i] - 'a';
                    if (!f[rt][j])
                    {
                        f[rt][j] = ++tot;
                        cnt[tot] = 0; 
                        memset(f[tot], 0, sizeof(f[tot]));
                    }
                    rt = f[rt][j];    ++cnt[rt];
                }
            }
            if (s[0] == 's')
            {
                int rt = 1;
                for (int i = 0, j; x[i]; i++)
                {
                    j = x[i] - 'a';
                    if (!(rt = f[rt][j]))
                    {
                        printf("No\n"); rt = 0; break;
                    }
                }
                if (rt) printf("Yes\n");
            }
            if (s[0] == 'd')
            {
                int rt = 1;
                for (int i = 0, j; x[i]; i++)
                {
                    j = x[i] - 'a';
                    if (!f[rt][j]) { rt = 0; break; }
                    else rt = f[rt][j];
                }
                if (!rt) continue;
                int tr = 1;
                for (int i = 0, j; x[i]; i++)
                {
                    j = x[i] - 'a';
                    if (!f[tr][j]) break;
                    else
                    {
                        int k = f[tr][j];
                        cnt[k] -= cnt[rt];
                        if (!cnt[k]) k = f[tr][j] = 0;
                        tr = k;
                    }
                }
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值