2016"百度之星" - 资格赛(Astar Round1) C

Problem Description

度熊手上有一本神奇的字典,你可以在它里面做如下三个操作:

1、insert : 往神奇字典中插入一个单词

2、delete: 在神奇字典中删除所有前缀等于给定字符串的单词

3、search: 查询是否在神奇字典中有一个字符串的前缀等于给定的字符串
Input

这里仅有一组测试数据。第一行输入一个正整数N(1≤N≤100000)N (1\leq N\leq 100000)N(1N100000),代表度熊对于字典的操作次数,接下来NNN行,每行包含两个字符串,中间中用空格隔开。第一个字符串代表了相关的操作(包括: insert, delete 或者 search)。第二个字符串代表了相关操作后指定的那个字符串,第二个字符串的长度不会超过30。第二个字符串仅由小写字母组成。

Output

对于每一个search 操作,如果在度熊的字典中存在给定的字符串为前缀的单词,则输出Yes 否则输出 No。

Sample Input
5
insert hello
insert hehe
search h
delete he
search hello
Sample Output
Yes
No

【题意】如上。
【分析&解题思路】字典树,每个节点记录一个经过当前节点的单词出现的次数。
【AC代码】
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
typedef struct node{
    int num;
    node *next[30];
    node(){
        memset(next,0,sizeof(next));
        num=0;
    }
}Trie;
char op[32],s[32];
void Insert(node *root,char *s){
    node *p=root;
    for(int i=0; s[i]; i++){
        int x=s[i]-'a';
        if(p->next[x]==NULL) p->next[x]=new node;
        p=p->next[x];
        p->num++;
    }
}
int Search(node *root,char *s){
    node *p=root;
    for(int i=0;s[i];i++){
        int x=s[i]-'a';
        if(p->next[x]==NULL) return 0;
        p=p->next[x];
    }
    return p->num;
}
void Delete(node *root,char *s,int cnt){
    node *p=root;
    for(int i=0;s[i];i++){
        int x=s[i]-'a';
        p=p->next[x];
        p->num-=cnt;
    }
    for(int i=0;i<30;i++)p->next[i]=0;
}

int main(){
    int n;
    scanf("%d",&n);
    Trie *root=new node;
    for(int i=0;i<n;i++){
        scanf("%s %s",op,s);
        if(op[0]=='i'){
            Insert(root,s);
        }else if(op[0]=='s'){
            int ans=Search(root,s);
            if(ans) puts("Yes");
            else    puts("No");
        }else{
            int cnt=Search(root,s);
            if(cnt) Delete(root,s,cnt);
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值